Platform Slowness
Incident Report for eloomi Status page
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 17:49 CEST
Investigating
Some customers may experience slow speeds on their platforms. Our engineers are working hard to resolve the issue. We will send updates as the issue progresses.
Posted Aug 16, 2023 - 17:18 CEST
This incident affected: eloomi People (eloomi People web application).